ZTE Blade III rootolás

Néhány nap híján egy hónapos a Blade III, és elérkezettnek láttam az időt arra, hogy rootoljam. Már eleget használtam ahhoz, hogy megállapítsam, ebben az árkategóriában jó vétel, és egy darabig biztosan megmarad az itthoni mobil flotta tagjai között.

Lássuk, miért rootoltam. Először is azért, mert volt rá lehetőségem (hogy ne jöjjek ki a gyakorlatból). Másodszor, mert úgyis meg fogjátok kérdezni hogyan kell, és szívesebben válaszolok a kérdésekre úgy, hogy már én is megcsináltam, és végül azért, mert van néhány olyan funkció, aminek a hsználatához sok esetben rootolt telefonra van szükség.

Ilyen például a képernyőmentés, amely miatt sok programot kipróbáltam, de végül a Zsolto által ajánlott vált be (Screenshot UX), és még az is fizetős volt (nem is olcsó, a maga 951 forintjával).

Most jöhet a hogyan. Most is, mint mindig, a legfontosabb olvasnivaló, még a cikk elején: a rootolás veszélyes dolog, nagy odafigyelést, és valamennyi hozzáértést is kíván. Ha valamit rosszul csinálsz, legrosszabb esetben a macskád játékszere lehet az, ami eddig a kedvenced volt. Ráadásul, ha a rootolt készülékedet viszed be a garanciális szervizbe, még a garanciát is megvonhatják ! Végül: sem én, sem a navigyurci.hu nem vállal felelősséget azért, ha a rootolás/custom rom felrakása során valami nem jól sikerül.

Az első teendő a készülék drivereinek a telepítése volt. A ZTE Blade III drivere egy *.exe fájl segítségével települ, ebben semmi ördöngősség nincs. A fastboot driver azonban csak bootloader módban (rootolás, vagy a ClockworkMod Recovery telepítése közben) installálható, azaz csak ekkor fogja a Windows hiányolni azt. Az illesztőprogramokat innen töltheted le.

Ezután következhet a rendszergazda jog megszerzése (rootolás). A rootoláshoz szükséges programot letöltheted innen. Ugyanitt a telepítéséhez is találsz leírást (Android Fans Fórum).

Némi megjegyzés a leíráshoz: nálam először lefutott a program, majd az újraindulás után, bekérte a PIN kódot, ennek beütése után ismét újraindult, de ekkor már rootolva volt.

Én még feltettem a ClockworkMod Recovery-t is, mert számomra ennek segítségével a legegyszerűbb a működő készülék mentése.

A CWM telepítéséhez szükséges szoftver innen tölthető le. Amint láthatjátok, ez is hibátlanul működik. Az 1-es “kapcsoló” a CWM Recovery-t, míg a 2-es a gyári Recoveryt telepíti.

Ui: Egyre többet omlik össze a gyári launcher, és ilyenkor szinte megáll a telefon, illetve “támadnak” a kijelzőről már rég eltávolított ikonok… Muszáj keresni valami megoldást, mert most kezd nagyon bosszantani a dolog. Jó lenne megúszni a custom rom felrakását, mert nem sok kedvem van újratelepíteni az egész telefont…

Frissítve: egyelőre a régen (T-Mobil Pulse) már használt ADW Launchert telepítettem fel. Teszt folyamatban (az első nap hibamentes volt, gyors, és nem omlik össze, ráadásul ingyenes is). Ha te is kipróbálnád, akkor letöltheted innen.

Az első tapasztalatok az ADW Launcher-ről: gyors, az elmúlt időben egyszer lassult le, összeomlást nem tapasztaltam. Már beállítottam alapértelmezettnek is. A hiba, hogy a törölt ikonokat visszapakolja az asztalra a launcher, teljesen megszűnt!

Legközelebb a gyári állapot visszaállítása, és az eredeti újr telepítésének lehetőségét vesszük szemügyre.

Kapcsolódó cikkek:

http://navigyurci.hu/2012/12/11/egy-ujabb-androidos-kutyu-zte-blade-iii-eloszo/
http://navigyurci.hu/2012/12/13/zte-blade-iii-kicsomagolas/

18 hozzászólás
  1. avatar
    bandika

    Hali!

    Sajnos én is azzal a problémával küszködök, mint Gabo85.

    Minden kis szarság telepítve van. Mindent leellenőriztem, be van kapcsolva az összes hibakeresés, telepítés stb. funkció, a program mégis hót süket.

    Elfut odáig, hogy “Running”. Ezt követően azonnal rábökök az adatok visszaállítása gombra; kiírja, hogy a visszaállítás megkezdődött, majd, hogy sikeres volt, a script pedig így is addig fut, míg ki nem kapcsolom…

    Ötlet esetleg?

    • avatar
      bandika

      Semmit nem szedtem le rá. Gyárilag Android 4.0.4 volt rajta, és azóta a programfrissítéseken kívül semmi komolyabb nem történt vele. Na jó, egy hálózatfüggetlenítéstől eltekintve. De ha jól értesültem, az ilyesmi nincs komolyabb hatással egy telefon lelkivilágára…

      Köszönöm a választ; mindenképp utánanézek a korábbi verziónak!

    • avatar

      Én arra tippelek, hogy a Bin4ry alkalmazás egy régebbi verziója volt abban az időben letölthető (most a v33-nál jár már), amivel még működött, de a mostani-val már nem. Egészen pontosan erre a verzióra gondolok:

      This script will root your Android phone with adb restore function
      Script by Bin4ry (thanks to Goroh_kun and tkymgr for the idea)
      Idea for Tablet S from Fi01_IS01
      (18.11.2012) v16
      ported to Linux by Kamistral (15.09.2012)
      updated by codeworkx (01.10.2012)

      Ezt próbáld megkeresni a neten, és remélhetőleg ezzel működni fog. Esetleg megkérdezheted a fejlesztőt is, lehetséges-e ez:
      http://forum.xda-developers.com/showthread.php?t=1886460

      Ugyanez visszafelé is igaz lehet, hogy a ZTE Blade III.-ra volt közben frissítés, bár ezt nem nagyon hinném, de te biztosan tudod, mit töltöttél éle rá.

  2. avatar
    Gabo85

    Szia!
    Multkor annyiba maradt a root, mert nem volt annyira fontos, de most kellene.
    Szóval továbbra sem fut le rendesen a SCRIPT!
    Eddig jut el:

    http://kepfeltoltes.hu/view/140105/13285395651_www.kepfeltoltes.hu_.jpg

    Driver fönt van, és az eszközkezelőben megfelelően, ADB eszközként látja.
    De semmi.

    Ötlet?

    Köszi.

    • avatar

      @ Gabo85 Szia, ezt mondja az üzenet: “a végén azt mondja, hogy nyomd meg a cuccon a Restore gombot, és ha minden oké, akkor jön egy üzenet, ha nem, akkor ez a zöld szöveg fog futni örökké.” Van Restore gombod?

  3. avatar
    Gabo85

    Hali.
    Vigigcsináltam, a SCRIPT lefutott, de nem indúlt újra.
    Teljesen gyári ROM van rajta.
    Mi lehet a baj?
    Ez most így nem csinál semmit?

    Köszi.

  4. avatar
    stmarci

    sziasztok! olyan problémám lenne, hogy megcsináltam a root-ot újraindult a telefon úgy néz ki,hogy minden rendben DE! elindítok egy root checker-t és azt jelzi, hogy nincs rootolva a telefon… két programmal is ellenőriztem se semmi. mi lehet a gond?

  5. avatar
    rfutar

    Üdv! Csak egy apró megjegyzés. Nálam (gyári szoft , nova launcher prime ) a kepernyomentes a power + hang le gombokkal alapból mukodik a blade 3-on.

  6. avatar
    apeelme

    Az alap AOSP-ben (is) rendelkezésre áll. ( https://android.googlesource.com/platform/frameworks/base/+/android-4.0.3_r1/packages/SystemUI/src/com/android/systemui/screenshot/ )
    Ahhoz hogy ezt a gyártók “letiltják”, nem sok közünk van sajnos. :(

  7. avatar
    Zsolto

    Hát, én eddig két darab ICS-es készüléken próbáltam a dolgot (Xperia Live Music és Alcatel OT995), és egyiken se működött a dolog. :S

  8. avatar
    apeelme

    ICS-en mindenféle trükközés vagy root nélkül a Hangerő LE és POWER gomb egyidejű megnyomásával készíthetsz képet az aktuális képernyőről. ;)

Szólj hozzá te is a cikkhez!

A hozzászóláshoz jelentkezz be. Nem vagy még tag? Regisztrálj!


Weboldalunk használatával jóváhagyja a cookie-k használatát a Cookie-kkal kapcsolatos irányelv értelmében.